Samsung Issues Warning for 40 million Galaxy and Note users

Samsung Issues Warning for 40 million Galaxy and Note users

Samsung Issues Warning for 40 million Galaxy and Note users

Samsung officially has confirmed the security vulnerabilities this week. It has mainly confirmed that security vulnerabilities affect Galaxy devices such as S8, S9, S10, S10e, S10 plus, S10 5G, and Note devices Note9, Note 10, Note 10 Plus as well. Samsung has confirmed it while they are doing the October routine security maintenance (SMR) release rolls out to their Galaxy Device users.

Samsung Issues Warning

In the October routine security maintenance, it has stated that it has a critical vulnerability, and it also mentioned that three vulnerabilities are rated very “high.” In all those vulnerabilities, there are 21 security issues covered; in those 21, 17 are related to Samsung’s “One” user interface. The other four are about the Android interface.

If you’re wondering what’s the present status and what you have to do means check them below:

Android Vulnerabilities:

Firstly, we have to look at Android vulnerabilities. If you want precise information about the Google Android vulnerabilities, then this report from Kate O’Flaherty will help you out.

In that post, you can find out the patches to fix these vulnerabilities, including the critical rate fixes. To stay away from these vulnerabilities, you have to update your device as soon as possible. 

Samsung Galaxy Specific Security Warnings:

In the latest October patches update, Samsung has included patches from Google. This affects the Galaxy 10 users and other galaxy and Samsung users as well. Along with these, there are always a bunch of security vulnerabilities that impact Galaxy 9 and Galaxy 8 users. 

Among these, the galaxy nine vulnerability is rated highly because it is critical: SVE-2019-15435. This vulnerability affects both Note 9 and Galaxy S9 devices. Even though the details are sketchy, but the exact information is “privately disclosed,” and its disclosed to protect users until patches are installed on their devices.

As per statistics, over 30 million Samsung Galaxy 9 smartphones are sold, and 10 million galaxy note 9 devices are sold. So, a total of 40 million users should be aware of this vulnerability.

What is Critical Galaxy 9 and Note 9 Vulnerability?

The SVE-2019-15435, as mentioned earlier, is the vulnerability of Galaxy 9 and Note 9. About this vulnerability, Samsung hasn’t disclosed any data. But as per our knowledge and as per Samsung hint. This vulnerability is about “Enhancement in IMEI security mechanism” IMEI should be enhanced to improve protection against the potential IMEI manipulation.” 

This update also relates to the method of IMEI blacklisting. Usually, it prevents stolen devices from being resold easily. Any vulnerability that gets around this kind of protection makes that device involved in the stolen activity. 

Now with all these, most of you might be wondering whether to update their device or not.

If you are thinking about that, then i will answer that.

Should you really update your device now?

You should update it as soon as possible. However, you dont have to worry about the previously updated failures because every time it can’t be wrong.

Always updating the latest updates on your smartphone can help you stay away from lots of security vulnerabilities. Once you disclose that opportunity to the criminals, then you will have less risk of cracking and hacking on your device.

Nidhi Mahajan

Leave a Reply

%d bloggers like this: